Contacting Cirrus Logic Support

For all product questions and inquiries contact a Cirrus Logic Sales Representative.
To find the one nearest to you go to www.cirrus.com

IMPORTANT NOTICE

Cirrus Logic, Inc. and its subsidiaries ('Cirrus') believe that the information contained in this document is accurate and reliable. However, the information is subject to change without notice and is provided “AS IS” without warranty of any kind (express or implied). Customers are advised to obtain the latest version of relevant information to verify, before placing orders, that information being relied on is current and complete. All products are sold subject to the terms and conditions of sale supplied at the time of order acknowledgment, including those pertaining to warranty, indemnification, and limitation of liability. No responsibility is assumed by Cirrus for the use of this information, including use of this information as the basis for manufacture or sale of any items, or for infringement of patents or other rights of third parties. This document is the property of Cirrus and by furnishing this information, Cirrus grants no license, express or implied under any patents, mask work rights, copyrights, trademarks, trade secrets or other intellectual property rights. Cirrus owns the copyrights associated with the information contained herein and gives consent for copies to be made of the information only for use within your organization with respect to Cirrus integrated circuits or other products of Cirrus. This consent does not extend to other copying such as copying for general distribution, advertising or promotional purposes, or for creating any work for resale.

CERTAIN APPLICATIONS USING SEMICONDUCTOR PRODUCTS MAY INVOLVE POTENTIAL RISKS OF DEATH, PERSONAL INJURY, OR SEVERE PROPERTY OR ENVIRONMENTAL DAMAGE (“CRITICAL APPLICATIONS”). CIRRUS PRODUCTS ARE NOT DESIGNED, AUTHORIZED OR WARRANTED FOR USE IN PRODUCTS SURGICALLY IMPLANTED INTO THE BODY, AUTOMOTIVE SAFETY OR SECURITY DEVICES, LIFE SUPPORT PRODUCTS OR OTHER CRITICAL_APPLICATIONS. INCLUSION OF CIRRUS PRODUCTS IN SUCH APPLICATIONS IS UNDERSTOOD TO BE FULLY AT THE CUSTOMER’S RISK AND CIRRUS DISCLAIMS AND MAKES NO WARRANTY, EXPRESS, STATUTORY OR IMPLIED, INCLUDING THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR PARTICULAR PURPOSE, WITH REGARD TO ANY CIRRUS PRODUCT THAT IS USED IN SUCH A MANNER. IF THE CUSTOMER OR CUSTOMER’S CUSTOMER USES OR PERMITS THE USE OF CIRRUS PRODUCTS IN CRITICAL APPLICATIONS, CUSTOMER AGREES, BY SUCH USE, TO FULLY INDEMNIFY CIRRUS, ITS OFFICERS, DIRECTORS, EMPLOYEES, DISTRIBUTORS AND OTHER AGENTS FROM ANY AND ALL LIABILITY, INCLUDING ATTORNEYS’ FEES AND COSTS, THAT MAY RESULT FROM OR ARISE IN CONNECTION WITH THESE USES.

Cirrus Logic, Cirrus, the Cirrus Logic logo designs, CobraNet, and DSP Conductor are trademarks of Cirrus Logic, Inc. All other brand and product names in this document may be trademarks or service marks of their respective owners.

SPI is a registered trademark of Motorola, Inc.
Contents

1. Introduction .................................................................................................................... 1-1
  1.1 Overview ....................................................................................................................... 1-1
    1.1.1 Board Setup and DSP Composer Installation ......................................................... 1-1
  1.2 Controlling a Cirrus DSP on a Customer Board ............................................................ 1-1
    1.2.1 Hardware Set-up of USB Daughter Card ................................................................. 1-3
    1.2.2 Configuring DSP Composer to Control Customer Board ......................................... 1-3
    1.2.3 Pin-Out Requirements .............................................................................................. 1-5
      1.2.3.1 Recommended Connection ................................................................................. 1-5
      1.2.3.2 Minimum Connection Requirements ................................................................. 1-6
    1.2.4 Firmware Access and Licensing .............................................................................. 1-7

2. The DSP Composer Interface .......................................................................................... 2-1
  2.1 DSP Composer Main Window ......................................................................................... 2-1
    2.1.1 Tool Bar Reference .................................................................................................. 2-3
    2.1.2 Menu Bar ................................................................................................................ 2-3
      2.1.2.1 File Menu .......................................................................................................... 2-3
      2.1.2.2 Edit Menu ......................................................................................................... 2-6
      2.1.2.3 View Menu ....................................................................................................... 2-8
      2.1.2.4 Mode Menu ...................................................................................................... 2-8
      2.1.2.5 Tools Menu ...................................................................................................... 2-9
      2.1.2.6 Windows Menu ............................................................................................... 2-12
      2.1.2.7 Help Menu ..................................................................................................... 2-12
  2.1.1.1 Anatomy of an Element ....................................................................................... 3-1
  3. Elements .......................................................................................................................... 3-1
    3.1 Overview ....................................................................................................................... 3-1
      3.1.1 Anatomy of an Element ....................................................................................... 3-1
      3.1.2 Element Categories .............................................................................................. 3-2
        3.1.2.1 Audio In .......................................................................................................... 3-2
        3.1.2.2 Audio Out ...................................................................................................... 3-5
        3.1.2.3 System Block ................................................................................................. 3-6
  3.1.2.3 Minimum Connection Requirements ..................................................................... 1-6
    3.1.2.1 Recommended Connection ................................................................................. 1-5
  1.2.3.1 Recommended Connection ................................................................................. 1-5
  1.2.3.2 Minimum Connection Requirements ................................................................. 1-6
  1.2.4 Firmware Access and Licensing .............................................................................. 1-7
  1.2.4 Firmware Access and Licensing .............................................................................. 1-7

4. Project Design and Implementation ................................................................................. 4-1
  4.1 Choosing the Correct Mode ........................................................................................... 4-1
    4.1.1 Overview ................................................................................................................ 4-1
      4.1.1.1 Essential Elements ............................................................................................ 4-1
      4.1.1.2 Filling in the Rest ............................................................................................. 4-1
      4.1.1.3 Wiring the Configuration .................................................................................. 4-2
      4.1.1.4 “Save” and “Save As” .................................................................................... 4-2
    4.1.1.1 Essential Elements ............................................................................................ 4-1
    4.1.1.2 Filling in the Rest ............................................................................................. 4-1
    4.1.1.3 Wiring the Configuration .................................................................................. 4-2
    4.1.1.4 “Save” and “Save As” .................................................................................... 4-2
  4.2 Implementing a Project Design ....................................................................................... 4-1
    4.2.1 Run-time Control ..................................................................................................... 4-3
      4.2.1.1 Porting Configurations to an End System ......................................................... 4-3
      4.2.1.2 Snapshots ......................................................................................................... 4-4
      4.2.1.3 Deliverables ..................................................................................................... 4-5
    4.2.2 Inserting an Element ............................................................................................... 4-6
    4.2.3 Editing a Single Element ......................................................................................... 4-7
    4.2.4 Editing Multiple Elements ...................................................................................... 4-7

1.1 Overview ....................................................................................................................... 1-1

1.2 Controlling a Cirrus DSP on a Customer Board ............................................................ 1-1

2.1 DSP Composer Main Window ......................................................................................... 2-1

3.1 Overview ....................................................................................................................... 3-1

3.1.1 Anatomy of an Element ............................................................................................ 3-1

3.1.2 Element Categories .............................................................................................. 3-2

3.1.2.1 Audio In .......................................................................................................... 3-2

3.1.2.2 Audio Out ...................................................................................................... 3-5

3.1.2.3 System Block ................................................................................................. 3-6

4.1 Choosing the Correct Mode ........................................................................................... 4-1

4.1.1 Overview ................................................................................................................ 4-1

4.1.1.1 Essential Elements ............................................................................................ 4-1

4.1.1.2 Filling in the Rest ............................................................................................. 4-1

4.1.1.3 Wiring the Configuration .................................................................................. 4-2

4.1.1.4 “Save” and “Save As” .................................................................................... 4-2

4.1.1.1 Essential Elements ............................................................................................ 4-1

4.1.1.2 Filling in the Rest ............................................................................................. 4-1

4.1.1.3 Wiring the Configuration .................................................................................. 4-2

4.1.1.4 “Save” and “Save As” .................................................................................... 4-2

4.2 Implementing a Project Design ....................................................................................... 4-1

4.2.1 Run-time Control ..................................................................................................... 4-3

4.2.1.1 Porting Configurations to an End System ......................................................... 4-3

4.2.1.2 Snapshots ......................................................................................................... 4-4

4.2.1.3 Deliverables ..................................................................................................... 4-5

4.2.2 Inserting an Element ............................................................................................... 4-6
4.2.5 Wiring .............................................................................................................................. 4-9
  4.2.5.1 Adding a Single Wire ............................................................................................. 4-9
  4.2.5.2 Wiring Errors ....................................................................................................... 4-9
4.2.6 Gesturing......................................................................................................................... 4-9

5. Advanced Features .............................................................................................................. 5-5
  5.1 Pages and Flyoffs ........................................................................................................... 5-5
    5.1.1 Managing Design Pages ......................................................................................... 5-5
    5.1.2 Using Flyoffs to Wire Elements on Different Pages............................................... 5-5
  5.2 Advanced Wiring Techniques ......................................................................................... 5-6
    5.2.1 Wire Fanning .......................................................................................................... 5-6
    5.2.2 Wiring Multiple Outputs to Multiple Inputs......................................................... 5-6
    5.2.3 Waypoints ........................................................................................................... 5-7
  5.3 Revision History ............................................................................................................. 5-7

Figures

Figure 1-1. CDB-USB_MASTER Daughter Card ........................................................................ 1-2
Figure 1-2. CDB-MCU-DEBUG Board .................................................................................. 1-2
Figure 1-3. Project Properties ............................................................................................. 1-4
Figure 2-1. DSP Composer Main Window ................................................................................ 2-2
Figure 2-2. Project Properties Dialog .................................................................................. 2-4
Figure 2-3. Advanced Properties Dialog (for CS485XX) ..................................................... 2-5
Figure 2-4. User Preferences... Dialog ................................................................................ 2-11
Figure 3-1. The COMS2 Element ......................................................................................... 3-1
Figure 3-2. Example: COMS2 Control Panel ..................................................................... 3-2
Figure 3-3. Device Properties Dialog - Audio In block ...................................................... 3-2
Figure 3-4. Advanced Properties Dialog - DAI ................................................................. 3-3
Figure 3-5. Device Properties Dialog - SPDIF Rx ............................................................. 3-4
Figure 3-6. Device Properties Dialog - CODEC ADC ....................................................... 3-4
Figure 3-7. Audio Out device properties ............................................................................. 3-5
Figure 3-8. DAO Properties Dialog - Audio Out block ...................................................... 3-5
Figure 3-9. CODEC DAC Device Properties Dialog - Audio Out block ......................... 3-6
Figure 3-10. Device Properties and Advanced Properties - System Block ..................... 3-6
Figure 4-1. Minimum System Elements Example ............................................................ 4-1
Figure 4-2. Typical System Elements Example .................................................................. 4-1
Figure 4-3. Typical System Wiring Example ...................................................................... 4-2
Figure 4-4. Press the Go Button ......................................................................................... 4-2
Figure 4-5. Snapshots Manager Dialog ............................................................................. 4-4
Figure 4-6. Setting Undo Levels ......................................................................................... 4-8
Tables

Table 1-1. JP1 Customer Board Control Header Pin and Signal Assignments .............................................1-5
Table 1-2. JP1 Customer Board Control Header SPI Pin and Signal Assignments ........................................1-6
Table 1-3. JP1 Customer Board Control Header I2C Pin and Signal Assignments .....................................1-6
Table 2-1. DSP Composer Main Window Components ................................................................................2-2
Table 2-2. Tool Bar Commands .................................................................................................................2-3
Table 2-3. Expression Label Commands ....................................................................................................2-9
1.1 Overview

The DSP Composer tool is a graphical user interface (GUI) for evaluation and programming the Cirrus Logic 32-bit processor family. Some of the features offered by DSP Composer are as follows:

- Graphically configure Cirrus Logic standard sound-processing modules.
- Configure the operation of the various ICs on the Cirrus DSP Evaluation Board.
- Download firmware and configuration to the DSP.
- Perform run-time tweaking and control of the DSP.
- Generate configuration files for microcontroller code reference and/or use.
- Create custom DSP code from primitive elements. See the *DSP Composer® Primitive Elements Reference* for more details about primitive elements.

1.1.1 Board Setup and DSP Composer Installation

The relevant user’s manual for the board you are using contains important information about setting up your environment that is not repeated in this document. This guide assumes you have already performed:

- Hardware Setup: Connecting the Evaluation Board to a PC, powered speakers, and an audio source.
- Software Installation: Registering and installing the DSP Composer software and all necessary USB drivers.

1.2 Controlling a Cirrus DSP on a Customer Board

DSP Composer allows the user to exercise real-time control of a Cirrus DSP on a customer board using the USB daughter card, CDB-USB_MASTER that is shown in Figure 1-1, shipped with the Cirrus DSP Evaluation Board. The USB daughter card is used as a standalone board when controlling the customer board. The Cirrus DSP Evaluation Board is not needed to control the customer board.
DSP Composer also allows the user to exercise real-time control of CDB-MCU-DEBUG as shown in Figure 1-2.
1.2.1 Hardware Set-up of USB Daughter Card

Follow these steps to set up the connection between the PC and the customer board using the USB daughter card:

1. Jumper P2 on the CDB-USB-MASTER card to receive power from PC USB source.
2. Connect the USB cable (provided with Cirrus Evaluation board) from the USB port on the USB daughter card to the PC USB port.
3. Connect a cable from the 100 mil, 10 x 2, 20-pin JP1 Customer Board Control Header to an identical header on the customer board.

1.2.2 Configuring DSP Composer to Control Customer Board

To access the Customer Board DSP Control feature, select the check box “Use JP1 customer board control header” from the DSP Composer’s File → Properties dialog box. By selecting “Use JP1 customer board control header,” the following conditions take place:

- CDB-USB-MASTER board enables the 10x2 JP1 header
- All commands to control the CODEC and SPDIF Rx are no longer sent by DSP Composer
- The 50-pin connector to the Evaluation Board (JP3) becomes inactive.

Under the File → Properties dialog box, the field, “JP1 customer board configuration batch file” is used for entering the file name of a customer-specific batch file to control other ICs, such as CODECs or SPDIF Rx on the customer board, highlighted in Figure 1-3.
The “JP1 board type” menu is required to match the physical board, and the “JP1 customer board configuration batch file” text box can be used to send I^2^C commands to other board components using iic_cfg.exe.

To control other ICs, DSP control signals used by DSP Composer must be three-stated (high-impedance) to avoid contention. Cirrus recommends that I^2^C control of other devices be employed when required because extra chip-select signals are not available.
1.2.3 Pin-Out Requirements

1.2.3.1 Recommended Connection

A 10 x 2 standard header with the following pin-out in Table 1-1 must be on the customer board to mate the USB daughter card to the customer using the standard 100 mil 10 x 2 cable.

Table 1-1. JP1 Customer Board Control Header Pin and Signal Assignments

<table>
<thead>
<tr>
<th>JP1 Header Pin Number</th>
<th>DSP Signals</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>NC</td>
</tr>
<tr>
<td>2</td>
<td>NC</td>
</tr>
<tr>
<td>3</td>
<td>DSP_RST</td>
</tr>
<tr>
<td>4</td>
<td>DSP_HS0</td>
</tr>
<tr>
<td>5</td>
<td>DSP_BSY</td>
</tr>
<tr>
<td>6</td>
<td>DSP_HS1</td>
</tr>
<tr>
<td>7</td>
<td>DSP_IRQ</td>
</tr>
<tr>
<td>8</td>
<td>DSP_HS2</td>
</tr>
<tr>
<td>9</td>
<td>DSP_CS</td>
</tr>
<tr>
<td>10</td>
<td>DSP_HS3</td>
</tr>
<tr>
<td>11</td>
<td>SCP1_CLK</td>
</tr>
<tr>
<td>12</td>
<td>SCP1_GND</td>
</tr>
<tr>
<td>13</td>
<td>SCP1_MOSI</td>
</tr>
<tr>
<td>14</td>
<td>DSP_DBDA</td>
</tr>
<tr>
<td>15</td>
<td>GND</td>
</tr>
<tr>
<td>16</td>
<td>GND</td>
</tr>
<tr>
<td>17</td>
<td>SCP1_MISO/SDA</td>
</tr>
<tr>
<td>18</td>
<td>DSP_DBCK</td>
</tr>
<tr>
<td>19</td>
<td>GND</td>
</tr>
<tr>
<td>20</td>
<td>GND</td>
</tr>
</tbody>
</table>
1.2.3.2 Minimum Connection Requirements

If the 100 mil 10 x 2 cable is not used, the minimal connections are as follows:

Use the applicable configuration:

The minimum required connections for SPI* are:

Table 1-2. JP1 Customer Board Control Header SPI Pin and Signal Assignments

<table>
<thead>
<tr>
<th>JP1 Header Pin Number</th>
<th>DSP SPI Signals</th>
</tr>
</thead>
<tbody>
<tr>
<td>3</td>
<td>DSP_RST</td>
</tr>
<tr>
<td>5</td>
<td>DSP_BSY</td>
</tr>
<tr>
<td>7</td>
<td>DSP_IRQ</td>
</tr>
<tr>
<td>9</td>
<td>DSP_CS</td>
</tr>
<tr>
<td>11</td>
<td>SCP1_CLK</td>
</tr>
<tr>
<td>12</td>
<td>SCP1_GND</td>
</tr>
<tr>
<td>13</td>
<td>SCP1_MOSI</td>
</tr>
<tr>
<td>17</td>
<td>SCP1_MISO/SDA</td>
</tr>
</tbody>
</table>

The minimum required connections for I²C* are:

Table 1-3. JP1 Customer Board Control Header I²C Pin and Signal Assignments

<table>
<thead>
<tr>
<th>JP1 Header Pin Number</th>
<th>DSP I²C Control Signals</th>
</tr>
</thead>
<tbody>
<tr>
<td>3</td>
<td>DSP_RST</td>
</tr>
<tr>
<td>5</td>
<td>DSP_BSY</td>
</tr>
<tr>
<td>7</td>
<td>DSP_IRQ</td>
</tr>
<tr>
<td>11</td>
<td>SCP1_CLK</td>
</tr>
<tr>
<td>12</td>
<td>SCP1_GND</td>
</tr>
<tr>
<td>17</td>
<td>SCP1_MISO/SDA</td>
</tr>
</tbody>
</table>

* Note: If the HS3:0 mode select pins (see settings for these pins in the appropriate DSP Hardware User’s Guide) are not driven, the user must set the Communications mode in DSP Composer. Set the Communications mode from the **File** ⇒ **Properties** ⇒ **Board comm mode** dialog box.
1.2.4 Firmware Access and Licensing

Cirrus Logic licensing agreements must be completed in order to gain access to Cirrus Logic firmware offerings developed using third-party algorithms (for example, Dolby Digital, DTS, Dolby Headphone, etc.). Please contact your local FAE to guide you through this process. Once licensing has been established, you will receive specific installers (executable files) that will enable access and use of the firmware modules outlined in the licensing documents.

After running the executable for a particular installer, the user will be prompted for the location to install: use the same directory where the DSP Composer Application was installed. For example, the Dolby Digital Decoder technology will only become activated in DSP Composer after running the executable provided to licensed users.
This chapter describes the various components of the DSP Composer interface.

2.1 DSP Composer Main Window

Below is the DSP Composer main window. The following text describes the main window’s features.

![DSP Composer Main Window](Figure 2-1. DSP Composer Main Window)
The DSP Composer Main Window components are described in Figure 2-1.

Table 2-1. DSP Composer Main Window Components

<table>
<thead>
<tr>
<th>Call-out Number from Figure 2-1</th>
<th>Window Component</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.</td>
<td>Title Bar:</td>
<td>Displays the title of the application and the name of the project that is currently loaded.</td>
</tr>
<tr>
<td>2.</td>
<td>Menu Bar:</td>
<td>See Section “Menu Bar” for a description of each item in the menu.</td>
</tr>
<tr>
<td>3.</td>
<td>Tool Bar:</td>
<td>The tool bar contains shortcut buttons for some of the most frequently used menu items. See Section “Tool Bar Reference” for a description of each button.</td>
</tr>
<tr>
<td>4.</td>
<td>Activity Indicator:</td>
<td>Contains animation that indicates when DSP Composer is actively communicating with your development system. When this animation is flashing, it indicates that DSP Composer is currently connected to the board.</td>
</tr>
<tr>
<td>6.</td>
<td>Elements Window:</td>
<td>This is the palette of digital signal processing (DSP) elements (modules or primitives) that can be used in your configuration. See Chapter 3, &quot;Elements&quot;.</td>
</tr>
<tr>
<td>7.</td>
<td>Flyoffs Window:</td>
<td>This contains flyoffs that are used to send signals between the pages of a multi-page configuration.</td>
</tr>
<tr>
<td>8.</td>
<td>Design Canvas:</td>
<td>Contains the pages of your configuration. The canvas can contain multiple pages, initially there is only one page titled Page 1, which can be renamed by double-clicking the tab and entering text.</td>
</tr>
<tr>
<td>9.</td>
<td>Output Frame:</td>
<td>Contains tabs for the Compile Results and Debug functions. Error messages during project compile and download are shown here.</td>
</tr>
<tr>
<td>10.</td>
<td>Status Bar:</td>
<td>Indicates the current mode of DSP Composer and also the selected Element on the palette (drawing area).</td>
</tr>
</tbody>
</table>
2.1.1 Tool Bar Reference

The buttons on the tool bar described in Table 2-2 are simply shortcuts to commonly used menu items.

<table>
<thead>
<tr>
<th>Icon</th>
<th>Menu Command</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="File New" /></td>
<td>File ⇨ New</td>
<td>&lt;Ctrl&gt; + &lt;N&gt;</td>
</tr>
<tr>
<td><img src="image" alt="File Open" /></td>
<td>File ⇨ Open</td>
<td>&lt;Ctrl&gt; + &lt;O&gt;</td>
</tr>
<tr>
<td><img src="image" alt="File Save" /></td>
<td>File ⇨ Save</td>
<td>&lt;Ctrl&gt; + &lt;S&gt;</td>
</tr>
<tr>
<td><img src="image" alt="Edit Undo" /></td>
<td>Edit ⇨ Undo</td>
<td>&lt;Ctrl&gt; + &lt;Z&gt;</td>
</tr>
<tr>
<td><img src="image" alt="Edit Redo" /></td>
<td>Edit ⇨ Redo</td>
<td>&lt;Ctrl&gt; + &lt;Shift&gt; + &lt;Z&gt;</td>
</tr>
<tr>
<td><img src="image" alt="File Go" /></td>
<td>File ⇨ Go</td>
<td>&lt;F9&gt;</td>
</tr>
<tr>
<td><img src="image" alt="File Stop" /></td>
<td>File ⇨ Stop</td>
<td>no shortcut</td>
</tr>
</tbody>
</table>

2.1.2 Menu Bar

2.1.2.1 File Menu

**New** <Ctrl>+<n>

Creates a new configuration. This will launch a new copy of DSP Composer containing new configuration with a single, blank page in the design.

**Open** <Ctrl>+<o>

Presents the Windows file browser to select a previously saved project to open. If the current project is new and has not been modified in any way, the selected configuration will open in the current copy of DSP Composer; otherwise the configuration will be opened in a new copy of DSP Composer. You cannot have the same configuration open in two copies of DSP Composer at the same time.
Save  <Ctrl+s>
Save the current project to its current name. If the current project has not yet been given a name, the Save As... dialog will appear. Files are saved with the extension .cpa, which stands for “Conductor Project Archive”.

Save As...  <Ctrl+Alt+s>
Presents the Save As... dialog to enter a new name for the project.

Properties...

Presents the Project Properties dialog which allows you to specify the properties of the current configuration. These properties are used during the compile process, so changing the value here will take effect the next time you press Go.

Figure 2-2. Project Properties Dialog

- **PRAM size (Program RAM size)** lists the amount of RAM set aside for running applications on the DSP.
- **Control poll rate (x/sec)** indicates how fast DSP Composer requests new SNMP values from the device while connected. This affects how much network traffic is generated by the program, but it does not actually affect the compiled configuration.
- **Board Comm Mode** specifies communication mode used in the current project, which is either SPI or I²C.
- **Coefficient Ramp Time Constant(s)** specifies the time constant used for ramping
coefficients in the DSP. If the value is too large, the processor will appear to respond sluggishly to controls. If it is too small, you will hear audio artifacts when you adjust controls. The recommended value is 0.075 seconds.

- **Clip Hold Time(s)** specifies how long the clip light stays on after an element detects internal clipping.

- **Compile debug level** enables output of internal details of the compile process to the Compile Results window. This is probably only useful if you are talking to a technical support person.

- **Use JP1 Customer Board Control Header** check box indicates whether JP1 is jumpered on a USB daughtercard

Clicking the Advanced… button presents the Advanced Properties dialog shown in Figure 2-3. Most of the items here should not be changed.

![Advanced properties dialog](image)

Figure 2-3. Advanced Properties Dialog (for CS485XX)

**Recent Files**

This is a list of the four most-recently opened configurations. Choosing an item from the list is identical to choosing Open and selecting that file.

**Go <F9>**

Compile the configuration, choose the target, download the project to the target and control it.

**Stop**

Cease control communications with the processor.

**Exit**

Close the application. If you have made any changes to your configuration, you will be asked if you want to save.
2.1.2.2 Edit Menu

**Undo** (<Ctrl+z>)

Undo the last editing operation. The text of the menu item will change to indicate what operation will be undone. The number of levels of undo is specified in the Tools  User Preferences… dialog. By default you may undo the last 100 editing operations.

**Redo** (<Ctrl+Shift+z>)

Redo the last editing operation that was undone. When you perform any editing operation (except Undo), Redo becomes unavailable.

**Cut** (<Ctrl+x>)

Remove the selected objects from the configuration and place them in the clipboard. This menu item is only available in Edit mode when one or more objects are selected.

**Copy** <Ctrl+C>

In Edit mode, place a copy of the selected objects in the clipboard. This uses a private clipboard format that is only understood by DSP Composer.

In Gesture mode, copy the values of the selected controls to the clipboard. This uses a text format that is understood by most programs. When more than one control is selected, the values are separated by Tab characters.

**Paste** <Ctrl+v>

In Edit mode, prepare to insert the objects previously cut or copied to the clipboard. The cursor changes to a down-pointing arrow with a box indicating you need to select the location to insert the objects. If you press the <Esc> key, the operation is cancelled. When you click the mouse, the objects will be inserted.

In Gesture mode, paste the values from the clipboard into the selected controls.

In Edit mode, select object to be duplicated. The duplicate panel will display the controls for Orientation (Horizontally / Vertically), Number of copies and the Space between the duplicates.

**Delete** <Delete>

In Edit mode, delete the selected objects.

This item is not available in Gesture mode.

In Wire mode, delete the selected wire. If no wire is selected but a wiring port is selected, delete all of the wires connected to the port. If no port is selected but a device is selected, delete all of the wires connected to the device.

**Select All** <Ctrl+a>

Select all of the objects in the current window.

**Find** <Ctrl+f>

Select all of the objects in the current window.
Clear Find Highlight
Select all of the objects in the current window.

Align
Aligns selected objects.

- **Left** aligns the left edges of the selected objects with the left edge of the left-most selected object.
- **Top** aligns the top edges of the selected objects with the top edge of the top-most selected object.
- **Right** aligns the right edges of the selected objects with the right edge of the right-most selected object.
- **Bottom** aligns the bottom edges of the selected objects with the bottom edge of the bottom-most selected object.

Pack
Aligns selected objects closely together with no space between them.

- **Left** aligns the left edges of the selected objects with the left edge of the topmost selected object and adjust the vertical positions of the subsequent objects so they are packed in a column with no space between them.
  
  **Shortcut**: <Ctrl+l>

- **Top** aligns the top edges of the selected objects with the top edge of the left-most selected object and adjust the horizontal positions of the subsequent objects so they are packed in a row with no space in between them.

- **Right** aligns the right edges of the selected objects with the right edge of the topmost selected object and adjust the vertical positions of the subsequent objects so they are packed in a column with no space between them.

- **Bottom** aligns the bottom edges of the selected objects with the bottom edge of the left-most selected object and adjust the horizontal positions of the subsequent objects so they are packed in a row with no space in between them.

Arrange
Adjusts the order in which a selected objects are arranged on the Design page.

- **Bring to Front** adjusts the Z order of the selected object so it is in front of all other objects on the page.

- **Send to Back** adjusts the Z order of the selected object so it is behind all other objects on the page.

Copy Special
Copies specific information to the clipboard.

- **Picture (Enhanced Metafile)** copies a picture of the current page to the Windows clipboard in Enhanced Metafile format (.emf). This is a vector format that scales better than the
bitmap format obtained when you press <Print Screen>.

- **Label (Text)** copies the label(s) of the selected object(s) to the clipboard in text format (.txt). Each label will be on a separate line.

### 2.1.2.3 View Menu

**Zoom**
Affects the zoom factor in effect for the current window. Zooming, like panning, is cosmetic only. The zoom setting is not saved in the configuration and does not interact with **Undo/Redo**.

- **Satellite** zooms all the way out so the elements on the page are very small, as though viewed from space.
- **Out** <Ctrl+Page Up> zooms out by a factor of 2, making everything on the page half as big.
- **Normal** <Ctrl+Home> resets the zoom factor for the current page to the nominal value.
- **In** <Ctrl+Page Down> zooms in by a factor of 2, making everything on the page twice as big.
- **Microscope** zooms all the way in, making the elements on the page huge, as though viewed through a microscope.
- **Fit all** adjusts the zoom factor so all of the objects on the current page can fit within the current extents of the window.

**Show/Hide Output Frame** <F10>
Toggle the visibility state of the Output Frame. The Output Frame is the tabbed window at the lower right containing the **Compile Results** window and the **Debug** output window. The same result can be achieved by clicking on the tiny row of triangles that reside in the splitter between the **Design** frame and the **Output** frame.

**Show/Hide Utility Frame** <F11>
Toggle the visibility state of the **Utility** frame. The **Utility** frame is the tabbed window on the left containing the **Elements** window and the **Flyoffs** window. The same result can be achieved by clicking on the tiny row of triangles that reside in the splitter between the **Utility** frame and the **Design** frame.

**Show/Hide Status Bar** <F12>
Toggle the visibility state of the status bar.

### 2.1.2.4 Mode Menu

**Edit** <Ctrl+e>
Change to **Edit** mode. Edit mode allows you to move objects, edit their properties and delete them. Certain operations, such as inserting a new element, will switch to **Edit** mode automatically.

**Wire** <Ctrl+w>
Change to **Wire** mode. Wire mode is used to add, delete and arrange wires. See Section 4.2.5, "Wiring" on page 4-9.
**Gesture** \(<\text{Ctrl}+g>\)

Change to **Gesture** mode. **Gesture** mode is used to adjust control settings. After you press GO, if everything succeeds, **Gesture** mode is selected automatically. If you are not connected to the target system, **Gesture** mode has no effect. Section 4.2.6, "Gesturing" on page 4-9.

**Paint** \(<\text{Ctrl}+p>\)

Change to **Paint** mode. **Paint** mode is used to change the color of objects on the screen. The color palette will appear allowing you to choose a color by clicking on a desired color, the clicking on an object to change the object to the color you chose. Typing \(<\text{Ctrl}+p>\) will choose the color of the selected object. Change to another mode such as Gesture to close Paint window.

To change the background color of a window, you must use the **Page Properties** dialog, accessible by right-clicking on the **Pages** tab and choosing **Properties**…

### 2.1.2.5 Tools Menu

**Group** \(<\text{Ctrl}+l>\)

Bind together the selected objects into a group so their relative positions are always maintained. This item is only available if two or more objects are selected.

**Ungroup** \(<\text{Ctrl}+u>\)

Unbind the objects in a group so they may be moved individually. This item is only available if a group is selected.

**ExpressionLabel**...

The **ExpressionLabel** dialog box allows the user to assign:

- A series of labels to a selection of elements
- A series of names to a selection of flyoffs.

The series of names is generated by an **ExpressionLabeling** formula. A formula is comprised of 2 basic tokens: literal (normal) characters and commands. A command is a processing instruction surrounded by curly braces \("\{\}\"\) which generates a string based on the current iteration index.

There are 6 types of **ExpressionLabel** commands:

<table>
<thead>
<tr>
<th>Label Type</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>({X+=Y})</td>
<td>Auto-increment by Y, starting with X</td>
</tr>
<tr>
<td>({X+=Y/Z})</td>
<td>Auto-increment by Y, starting with X, every Z items</td>
</tr>
<tr>
<td>({X-=Y})</td>
<td>Auto-decrement by Y, starting with X</td>
</tr>
<tr>
<td>({X-=Y/Z})</td>
<td>Auto-decrement by Y, starting with X, every Z items</td>
</tr>
<tr>
<td>{label1,label2,label3}</td>
<td>Cycle-between label1, label2, and label3</td>
</tr>
<tr>
<td>{&quot;X}</td>
<td>Replace with wildcard series X</td>
</tr>
</tbody>
</table>
For example, the ExpressionLabel, Flyoff.\{1+=1\}, labels a set of flyoffs: Flyoff.1, Flyoff.2, Flyoff.3, and so on.

Another ExpressionLabel, Flyoff.\{mute,gain\}.\{1+=1/2\}, labels a series of flyoffs: Flyoff.gain.1, Flyoff.mute.1, Flyoff.gain.2, Flyoff.mute.2.

If the selected items already have text associated with them, the ExpressionLabel engine does its best to reverse engineer a formula that represents the progression. In the case that the engine cannot determine a pattern, it represents the series with a wildcard series.

For example, take a set of items with text Bob.1.input, Joe.2.input, and Frank.3.input. The engine will detect the numbering sequence as well as the .input suffix, but it will not be able to detect a pattern from Bob, Joe, and Frank so it will use a wildcard series. The generated ExpressionLabel formula will look like:

\{*0\}{1+=1}.input

The *0 will be replaced with the series defined by first (0-based) wildcard. If additional wildcards were detected, their numbers would be represented by their index. To change the previous example to Input.1.Bob, Input.2.Joe, and Input.3.Frank you would change the automatically generated ExpressionLabel formula to:

Input.\{1+=1\}^{*0};

Replace Text... <Ctrl+H>

Brings up the Replace Text dialog. This dialog allows you to replace the text occurring on the surface of the selected elements. In this dialog you enter the text to find and the new text to replace it with. This menu item is only available if at least one element is selected.

Define User Device...

Brings up the Define User Device dialog. This menu item is typically used when you have created and wired a schematic within a hierarchical block, and you want to save this block to the Elements window so it can be easily reused in future configurations. If an element is not selected, this menu item is not available. The Define User Device dialog allows the user to enter the name for your creation, or select an existing name if you wish to overwrite the previous version. Your element will show up in the User Devices panel at the bottom of the Elements window.

Properties <ALT+Enter>

Depending on the type of the object or objects selected, bring up the Device Properties dialog, the Control Properties dialog or the Graphic Properties dialog.

Update All Out of Date Elements

If you have installed a DSP Composer update and subsequently opened a project saved with an earlier version, you may use this command to force a refresh of the existing elements in the project.

User Preferences...

User Preferences dialog controls the preferences shared by all copies of DSP Composer, although some changes may not take effect until the program is restarted.
**Default View Color**
Selects the color of all subsequently created pages. Click on the color box to bring up the color chooser dialog box.

**Draw Grid**
Displays a subtle grid that looks like graph paper.

**Grid (Size)**
Specifies the size of the grid, if it is turned on. You should make the grid a multiple of the snap value.

**Snap**
Specifies the unit to which the position of elements on the screen is quantized. This will not change the position of any elements until the next time you move them.

**Undo Levels**
Specifies the count of operations that can be undone with *Edit*  *Undo*. The *Undo* history is stored in memory, so you may want to reduce this number if your computer does not have a lot of memory.

**Enable Hover Popups**
Enables hover text to popup near the cursor when you hold the mouse over a control or a wiring port.

**Deep Locate**
Has no effect in this version of the software.

**Snapshots...**
See Section 4.2.1.2, "Snapshots" on page 4-4 for a description of this menu item.
**Generate Deliverables...**
See the Deliverables section for a description of this menu item.

**Debug**
Pay no attention to the items in the debug menu. None of these items are necessary for normal use of DSP Composer, so they are not documented here.

### 2.1.2.6 Windows Menu

**Next Window**
Switches focus to the next running copy of DSP Composer.
Shortcut: <Ctrl> + <Alt> + <N>

**Previous Window**
Switches focus to the previous running copy of DSP Composer.
Shortcut: <Ctrl> + <Shift> + <N>

**Next Page**
Switches to the next page in the design. If you have a hierarchical block open that contains multiple pages, this command will change to the next page in that block.

**Previous Page**
Switches to the previous page in the design. If you have a hierarchical block open that contains multiple pages, this command will change to the previous page in that block.

**List of Open Projects**
Presents a list that contains the names of the projects open in all copies of DSP Composer that are currently running and allows you to quickly switch between them.

### 2.1.2.7 Help Menu

**Users Guide**
Will bring up the DSP Composer User’s Guide.

**About**
Displays the version of DSP Composer. Click anywhere to make the window disappear.
3.1 Overview

Elements are the basic digital signal processing blocks that make up your DSP configuration. Elements can be viewed in the Elements Window, which is a tree view that categorizes the elements by function. Click on + and - in the tree view to expose or hide the elements in each category. Note that the term device is sometimes used in the DSP Composer software as a synonym for an element.

3.1.1 Anatomy of an Element

The following is an example of an element:

![Input Port Output Port](image)

**Input Port**
Triangle located along the left edge. This is where audio signals enter the element.

**Output Port:**
Triangle located along the right edge. This is where audio signals leave the element.

**Control Panel**
Most elements have a control panel that can be opened by double-clicking on the element. The control panel essentially is a reflection of the host control interface for that specific element as is documented in its firmware application note. For example, the COMS2 Control Panel contains a control to enable/disable the COMS2 module - toggling this button sets/clears the variable in the DSP firmware related to this function.

The same applies for all other controls seen in the control panel. One of the useful features of the control panel is that the controls are adjustable during run-time - this allows DSP Composer to interact with the DSP device in a similar way as would a host-microcontroller in an actual system.

**Note:** Users are advised to cross-reference the respective application note for each element in order to gain a full understanding of the run-time features and capability of that element.
Figure 3-2. Example: COMS2 Control Panel

Device Properties

This is a dialog box that allows you to configure the various properties of an element. The Properties dialog for an element is displayed by clicking on the element to select it and either choosing Tools ⇒ Device Properties, or pressing <Alt> + <Enter>, or right-clicking on the element and selecting Device Properties... from the pop-up. Not all elements have a device property. For example, in the case of SPP there is no device properties to edit. An example of an element that has device properties is the Audio In block. Its device properties is shown below.

Figure 3-3. Device Properties Dialog - Audio In block

3.1.2 Element Categories

3.1.2.1 Audio In

This is a group of three elements that collectively define the nature of the incoming audio to the DSP. This group has overall properties in the device properties of the Audio In block as in
“Device Properties Dialog - Audio In block”. The three elements are the DSP DAI Port, ADC (CODEC), and the SPDIF Receiver. Details of each component of this element is as follows:

**DAI Port (DSP)**

This element allows the user to set up the input hardware configuration of the DAI port on the DSP. A description of the parameter settings for the device properties of this element are indicated below:

- **SCLK polarity**: Allows the user to select when data is valid
- **LRCLK polarity**: Allows the user to select which signal is L and R
- **Temperature Grade**: All evaluation boards are populated with commercial-grade chips by default.

**Ref Clock**

Set to the frequency of the crystal driving the DSP (Y1). This is the reference clock used to determine the clock dividers needed to derive Fs in ADC-only applications. If this number changes, then all dividers for LRCLK/SCLK will change by the same ratio (for example, @24.576 MHz MCLK/512 = 1Fs = LRCLK, @12.288 MHz MCLK/256 = 1Fs = LRCLK).

**Note:** Refer to the Hardware User’s Manual for the DSP for information about the device you are configuring.

![Audio In Schematic](image)

**Figure 3-4. Advanced Properties Dialog - DAI**

**SPDIF Rx**

**Note:** Refer to *CDB485XX User’s Guide* for configuration options.
Analog-to-Digital CODEC (ADC)

**Note:** Refer to *CDB485XX User’s Guide* for information on configuring the ADC.
3.1.2.2 Audio Out

The Audio Out group of elements collectively define the audio output from the DSP. This overall properties for this group are accessed in the “Audio Out device properties” dialog shown in Figure 3-7. The group Elements are the DSP DAO Port, DAC (CODEC), and the SPDIF Transmitter:

![Figure 3-7. Audio Out device properties](image)

Each of the Audio Out elements are described next.

DAO Port (DSP)

Note: Refer to the Hardware User’s Manual for the DSP for information about configuring the DAO Port.

![Figure 3-8. DAO Properties Dialog - Audio Out block](image)
DAC CODEC

There are no device properties because the DAC slaves to the Audio Out settings.

**Note:** Refer to CDB485XX User’s Guide - Section 5.2.2

3.1.2.3 System Block

The System Block is representative of the OS firmware module. It includes the controls that are outlined in the OS Manager. In addition, since the PCM decoder is integrated into the OS, this element also contains the controls for the PCM_INPUT_MODE, refer to Figure 3-10, which is the System block for a CS49531x DSP.

![Figure 3-9. CODEC DAC Device Properties Dialog - Audio Out block](image)

![Figure 3-10. Device Properties and Advanced Properties - System Block](image)
Advanced Device Properties

This pop-up menu allows the user to enter custom configuration files. These are supplied by the factory upon special request for features not available.

**Note:** See the Application note AN298 (CS485XX)
4.1 Choosing the Correct Mode

There are four modes available in DSP Composer: Edit, Wire, Gesture, and Paint. Most of the tasks performed when using DSP Composer to create and edit configurations require you to be in Edit mode. Use Mode ⇒ Edit to select Edit mode or use the shortcut <Ctrl> + <E>.

4.1.1 Overview

4.1.1.1 Essential Elements

Every project created in DSP Composer must have the following three elements as part of the configuration:

- Audio In
- Audio Out
- System Block

![Figure 4-1. Minimum System Elements Example](image)

To insert elements, follow the procedure described in "Inserting an Element" on page 6.

4.1.1.2 Filling in the Rest

Once the three elements shown above have been inserted, the user needs to select elements to populate the various overlays: Matrix Processing Module Overlay (MPM), Virtual Processing Module (VPM), and Post Processing Module (PPM) Overlay.

![Figure 4-2. Typical System Elements Example](image)
Sample projects for various firmware applications have been provided in DSP Composer. Go to File ⇒ Open and browse to the >CirrusDSP\CS485XX\projects\ folder. In this folder are several sample projects that exercise other modules.

In the example shown in Figure 4-2, the following configuration is realized:

- **MPM** - Passthru Element for the MPM Overlay
- **VPM** - Passthru Element for the MPM Overlay
- **PPM** - Standard Post Processing (SPP) for the PPM Overlay

### 4.1.1.3 Wiring the Configuration

Refer to “Wiring” on page 9 for more information on how to wire elements together and the various features of the Wire mode. Once the project has been wired, it should look as follows:

**Note:** The System Block element is not intended to be wired.

![Typical System Wiring Example](image)

**Figure 4-3. Typical System Wiring Example**

### 4.1.1.4 “Save” and “Save As”

DSP Composer projects are saved with the file extension .CPA which stands for Composer Project Archive. DSP Composer does not periodically save projects, so it is a good idea to save your work often.

### 4.2 Implementing a Project Design

Once the elements have been correctly wired and the DSP Evaluation board has been connected to the PC, and you are ready to listen to your configuration, click the Go! button on the Tool Bar or select File ⇒ Go or press <F9>.

![Go Button](image)

**Figure 4-4. Press the Go Button**

The Go action initiates a series of three distinct processes:
• Check & Compile
• Deployment (Download)
• Connect (for gesturing/control).

Once the download of a project has taken place, the DSP will start decoding PCM audio input.

Next, each of the three processes are described in detail.

**Check and Compile**

Analyzes the configuration and generates the configuration or DSP code necessary to implement the project. If the compile fails for any reason you will get an error message and the *Compile Results* window will display details about why the compile failed. If the compile operation succeeds, the *Compile Results* window will display any warnings, if present as well as a table of DSP resources consumed by the configuration.

**Deployment (Download)**

Involves the configuration of the various board devices such as the SPDIF Rx, CODEC, and DSP. The *Deployment* command downloads the firmware and relevant hardware and software configuration to the DSP. In addition, it issues the kickstart command necessary for the DSP to start running the project.

**Connect**

Establishes communication with the development board running your configuration after DSP firmware has been downloaded and configured. Any changes you make to the settings (See “Gesturing” on page 9) are immediately transmitted to the development system and you can hear the effect in real time. DSP Composer is also continuously polling for *meter* and *clip* information and making that information visible in each element's control panel. While you are connected, the activity indicator at the far right side of the tool bar is animated.

### 4.2.1 Run-time Control

Once the DSP is running the project, it is possible to use DSP composer to control the system (run-time disabling/enabling various modes, volume control, bass management, and so on.). Run-time control involves the use of Gesture mode on the various Control Panel items for the various elements. Refer to “Gesturing” on page 9 to obtain additional information on how to do exercise run-time controls.

### 4.2.1.1 Porting Configurations to an End System

If you are developing an end product, you will need to write microcontroller code to adjust various settings of your configuration based on run-time user preferences (for example, making a Pro Logic II mode selection, or implementing another licensed decoder. DSP Composer can be used to generate various run-time configurations. The process involves the creation of *Snapshots* and *Deliverables*. 
4.2.1.2 Snapshots

A *Snapshot* is a file that saves the settings of *all* of the controls in your configuration.

During the run-time control of DSP Composer, the user can create various complex configurations (for example, a special Bass Manager setting with a particular Pro Logic II mode) with the intention of re-using them as a feature within an end system. A single project can have multiple snapshots, each of which reflects a different run-time configuration. The snapshot function may also be useful in the following scenarios:

- Perform a comparison between two different sets of configurations
- Capture multiple preset configurations for multiple audio processing modes in a single design.

After a snapshot is saved within a project file, the snapshot can be selected anytime the project is opened. DSP Composer will download the configurations for that snapshot to the DSP whenever it is loaded.

Snapshots are managed through the *Tools ➤ Snapshots...* menu item. This brings up the *Snapshots Manager* dialog. This item is only available if you are connected to the target system, and *Go* has been pressed, the project has successfully compiled, and the activity indicator is animated.

![Figure 4-5. Snapshots Manager Dialog](image)

**New**

Allows the user to enter a name for a snapshot. All of the control settings will be saved under this snapshot name. The user can also use this option to save new settings to an existing snapshot.

**Load**

If you select a snapshot name from the list and press *Load*, all of the control settings will be loaded from this snapshot and applied to your DSP device and the *Snapshots Manager* dialog will close.

**Delete**

If you select a name from the list and press *Delete*, the selected snapshot will be deleted.

To close the dialog box, click the red X in the upper right corner. Snapshot operations may not be undone with *Edit ➤ Undo* menu item.
4.2.1.3 Deliverables

Once the snapshots for the various required settings have been created, they have to be converted into configuration files that can be incorporated into the microcontroller code. To do this, select the desired snapshot configuration and then select the *Generate Deliverables* option from the *Tools* menu. This action generates and saves these configurations as text files to a specific location on the user’s computer. These files contain all the hexadecimal commands sent by DSP Composer to the DSP that created the specific snapshot configuration.

The output files created by the *Generate Deliverables* option are described next:

**board_cfg.bat**
This batch file contains the configuration settings for the various devices on the DSP Evaluation board (FPGA, SPDIF Rx, CODEC)

**preKickStart.cfg**
This file contains hardware configuration messages sent to the DSP pre-Kickstart.

**initial folder**
This folder contains all the default/initial software configurations after download. The software configurations files found in this folder are the following:

- audio_manager.cfg
- bass_manager.cfg
- cs49531.cfg
- decoder_dts.cfg
- delay_proc.cfg
- mpm_a_crossbar.cfg
- system_pcm.cfg
- tone_control_proc.cfg
- upby2.cfg

**initial.cfg**
This file contains all the default/initial software configurations after download.

**<snapshots_name> folder**
This folder contains the custom user configurations for the specific snapshot that was used to generate these deliverables:

- audio_manager.cfg
- bass_manager.cfg
- cs49531.cfg
• decoder_dts.cfg
• delay_proc.cfg
• mpm_a_crossbar.cfg
• system_pcm.cfg
• tone_control_proc.cfg
• upby2.cfg

<snapshots_name>.cfg
This file is a modified version of an initial.cfg file and contains the custom user configurations for the specific snapshot that was used to generate these deliverables.

postKickStart.cfg
Comprised of post-kickstart software configuration messages, if any.

load.bat
This file can be executed from the CS485XX DOS Console. It sequences through following tasks:
• Set up default directory and environment variables
• Send board configuration messages
• Boot DSP
• Download Firmware
• Soft boot DSP
• Send pre-kickstart messages (Hardware Configurations)
• Send initial configuration (Software Configurations)
• Kickstart DSP
• Send post-kickstart messages

4.2.2 Inserting an Element

Mode
Edit mode

Action
Drag the element with the left mouse button from the Elements window to a Design Canvas page and release the button at the location where you want the element to be placed.
To stop inserting an element during the middle of drag, press <Esc> to cancel it. You can also drag a category from the Elements window to the Design page. When you release the mouse button, you will see a popup menu containing the contents of that Category. When you select an element from the menu, it will be placed on the page. If you press <Esc> or click outside of the menu, the menu will disappear and nothing will be placed.

The Elements Reference document contains a description of every element available in the Elements window.

4.2.3 Editing a Single Element

Mode

Edit mode

DSP Composer has its own clipboard format which is only understood by DSP Composer.

Actions

- To select a single element, click on the element.
- To move an element around on its page, simply click on the element and drag it where you want it to be.
- To delete an element, click on it and press <Delete>.
- To change the text displayed on an element, click on it and type the desired text.
- To duplicate an element, press and hold the <Ctrl> key, click on the element, drag the element with the left mouse button, and release the mouse button before releasing the <Ctrl> key. This will leave a copy of the element at the location where you released the mouse button.

4.2.4 Editing Multiple Elements

Mode

Edit mode

Actions

All of the editing operations that you can perform in DSP Composer on a single element may also be performed on all selected elements simultaneously. Selected elements are displayed with a red border.

- To select multiple elements, click on the elements while holding down either the <Ctrl> or the <Shift> key. Holding down the <Ctrl> key will select only the elements you clicked on. Holding down the <Shift> key will select the elements you clicked on as well as all elements between it and the already selected element(s). You can also select multiple elements by dragging a box that intersects or encloses them. Holding the <Shift> key while dragging a box will select those elements while preserving the state of any previously selected elements.
- To deselect an element, hold the <Ctrl> key while clicking on an element to toggle its selection. Holding the <Ctrl> key while dragging a box will toggle the selected state of all of the elements that are inside or intersected by the box.
• To **clear the selection**, click on the *Design Canvas* somewhere between the elements.

• **Copy**: Selecting *Edit* → *Copy* or pressing <Ctrl> + <C> copies the selected elements to the clipboard.

• **Paste**: Selecting *Edit* → *Paste* or pressing <Ctrl> + <V> will change the cursor to a down-pointing arrow with a box behind it which allows you to choose the location at which to paste the elements.

• **Cut**: Selecting *Edit* → *Cut* or pressing <Ctrl> + <X> is identical to a copy command followed by a delete command.

• **Move**: To move the selected elements, click on one of them and drag to move them all. You will see the outlines of the selected elements move until you release the mouse button. To reverse a move in the middle of dragging process, press <Esc> to cancel.

• **Delete**: To delete all of the selected elements, press <Delete>.

• **Align & Pack**: To tidy up the arrangement of the selected elements, use the *Align* and *Pack* items in the *Edit* menu. Selecting *Edit* → *Pack* → *Left* or pressing <Ctrl> + <L> is particularly useful for making a column of elements line up.

• **Duplicating Selected Elements**: To duplicate the selected elements, press and hold the <Ctrl> key while dragging the elements and release the mouse button at the location where you want the duplicates to be placed.

• **Undo**: Almost everything you can do in DSP Composer can be undone by selecting *Edit* → *Undo* or pressing <Ctrl> + <Z>.

The number of steps of editing that can be undone is configured in the *Tools* → *User Preferences...* dialog shown in Figure 4-6.

![Figure 4-6. Setting Undo Levels](image-url)
• **Redo**: After undoing an action, the user can redo it selecting `Edit ⇒ Redo` or pressing `<Ctrl> + <Shift> + <Z>`. The Redo command is only available for reversing the most recent Undo action.

Note: The `Undo` and `Redo` commands do not apply to adjusting control values.

### 4.2.5 Wiring

**Mode:** Wire mode

**Actions**

You must add wires to your configuration to connect the elements and define the signal flow. To enter Wire mode, select `Mode ⇒ Wire` or press `<Ctrl> + <W>`. The cursor changes to a pair of pliers (ਸ) when you are in Wire mode. DSP Composer supports two types of wires, representing two types of data flow:

- **Audio Data wires**: These are thick or thin wires connecting the audio ports on the left and right edges of elements. A single audio data wire represents a block (usually 16) of 32-bit audio samples. Thick audio wires represent data flowing between major processing blocks, while thin audio wires represent data flowing between more primitive, low-level processing elements.

- **Control Signal wires**: These are thin yellow lines connecting the control signal ports on the top and bottom edges of an element. A single control signal wire represents 32 bits of data.

#### 4.2.5.1 Adding a Single Wire

To add a wire click on the output port (along the right edge) of an element and drag to the input port (along the left edge) of another element.

#### 4.2.5.2 Wiring Errors

If you wire the elements of your configuration such that you have created a feedback loop, the compile will fail.

### 4.2.6 Gesturing

**Mode** Gesture mode

To adjust an element’s control settings, you must be in Gesture mode. In Gesture mode the cursor becomes a hand icon. You select Gesture mode from the Choose `Mode ⇒ Gesture` menu item or the shortcut `<Ctrl> + <G>`.

Note: Gesturing will only have an effect if you are Connected, which means the activity indicator at the right edge of the tool bar is animated.

**Button Control**

To gesture a button control, click on it to toggle it between states.
Knob/Fader (slider) Control

To gesture a knob or fader (slider) item, click on the control and move the mouse up or right to increase the value, or down or left to decrease the value. When gesturing a knob, do not attempt to 'twist' the control by moving the mouse in a circle around it - use the method described above.

If you hold the <Shift> key down while gesturing a knob or fader, you will enter High Resolution mode where the control responds at one tenth of the speed it does normally.

Type Control

Some controls, such as the Type control in the High Pass and Low Pass filters allow you to choose from a list of legal values. When you click on the control, a menu pops up containing the legal values of the control. Simply click on the one of your choice.

Modifying Multiple Controls

All of the rules for multiple selection such as <Shift> + Click and <Ctrl> + Click as well as dragging a selection box and <Shift> or <Control> + dragging a selection box that are described in “Editing Multiple Elements” on page 7 apply to Gesture mode as well. Any gesture or typing operation that you perform while multiple controls are selected will apply to all of the selected controls.

Most controls also accept typed-in values. If you type in a value and press <Enter>, the value will be assigned to the selected control. You must be careful to specify the suffix character in some circumstances. For example, a time constant control may have a range of 10ms to 10s. Since the units of this control are seconds, when you type in 20, it is interpreted as 20 seconds which is clipped to the allowed range and the result is 10 seconds. If you desire to set the control to 20ms, you must type in 20m or 20ms.

Note: The Undo and Redo commands do not apply to adjusting control values.
5.1 Pages and Flyoffs

A configuration is not limited to a single Design Canvas page. The user can spread a configuration across multiple pages as a method of organizing it into functional sections, or to avoid scroll bars that occur when a large configuration is placed on one page.

5.1.1 Managing Design Pages

Some common users actions regarding the use of pages are:

- **Add a page**: Right-click in the space to the right of the tabs at the bottom of the Design Canvas window and choose Add Page. This will add a new page to the design with an automatically generated title (Page 4, Page 5, etc.)

- **Rename a page**: Double-click on the page tab and type a new name over the existing page name.

- **Rearrange page order**: Click on a page tab and drag it left or right to a new location.

- **Delete a page**: Right-click on a page tab and select Delete from the popup menu.

5.1.2 Using Flyoffs to Wire Elements on Different Pages

Flyoffs can be used to wire elements on different pages. A flyoff is an item on the page that gives a signal a name that can be referenced on a different page. Two flyoffs on different pages with the same name are wired together.

To create a flyoff, drag a wire or multiple wires by holding down the left mouse button in Wire mode and then clicking the right mouse button. This actions drops a flyoff for each wire you are dragging. Initially these flyoffs have no names, so they cannot yet be used to connect anything.

To give a flyoff a name, select in Edit or Wire mode. Double click the flyoff and begin typing the name or right-click it to open a flyoff naming dialog. Below the entry field is a list of the other flyoffs that you have already created that match what you have typed so far. This makes it easier to connect a flyoff to an existing flyoff without having to retype the entire name, simply click on it in the list or to avoid giving two flyoffs the same name.

If you give two flyoffs the same name and they are each connected to output ports of elements, the flyoffs and the wires connected to them will be displayed with a red outline. This indicates that you have created an illegal connection, and you must delete or rename one of them or the compile will fail.
Flyoffs that are not assigned a name or that are assigned a name that has no partner are displayed with a green outline. This indicates it is part of an incomplete connection. Once you assign another flyoff to the same name, the green border will disappear. If you compile while any of your wires or flyoffs are green, you will get a warning about an unconnected input or output.

The names of all of the flyoffs that you have created are displayed in the Flyoffs window. You can drag a name from this window to your Design page and where you release the mouse button, a new flyoff with this name is created.

It is a good idea to name related flyoffs using the convention of fields separated by periods. For example: Banana.1, Banana.2, Banana.3, etc. This causes the flyoffs to be arranged in the Flyoffs window in a category called, in this case, Banana containing 1, 2, 3, etc. If you drag the category from the Flyoff window to your Design page, you will deposit the entire contents of the category at once. This is very handy when working with bus-like groups of signals.

5.2 Advanced Wiring Techniques

5.2.1 Wire Fanning

Thin wires can fan out - this means that you can connect the output port of one element to the input ports of multiple elements. However, it is not possible to connect the outputs of multiple elements to the input port of a single element. If you need to do this, add a mixer.

5.2.2 Wiring Multiple Outputs to Multiple Inputs

To wire all output ports of an element to the corresponding input ports of another element, click in the center of the first element and drag the mouse pointer over the second element and release the mouse button.

If you want to do this in the reverse, drag to the left. The direction you move the mouse immediately after clicking the mouse determines whether you begin dragging from the inputs ports (drag left), the output ports (drag right), or the enable port (drag up).

You can wire from an ad-hoc selection of ports, as long as they are all the same type, by selecting them using <Ctrl> + Click and then dragging from one of them.

If you are dragging multiple wires, either from an element or from an ad-hoc selection of ports and you want to connect the wires to a column of devices, drag the wires over a port of the top device in the column and release the mouse button.

If you are dragging wires from multiple input ports and you want them all to connect to a single output port, hold the <Shift> key as you drag over the output port (the cursor will show a “G”, indicating you are ganging wires) and release the mouse button.
5.2.3 Waypoints

Waypoints are used to establish and exercise control over routing wires. Common actions regarding the waypoints are:

- **Creating a waypoint**: By clicking on any part of a wire and dragging it, a Waypoint is created that allows wire to be routed in a manner that is satisfactory to the user.

- **Moving a waypoint**: Once the waypoint is placed, return to Edit mode (<Ctrl> + <E>) to move it again.

- **Removing a waypoint, but not the wires connected to it**: When a waypoint is selected in Wire mode and <Delete> is pressed, the waypoint will be removed, and the wire will travel in the most efficient route between the ports it connects.

- **Removing a waypoint, and the wires connected to it**: When a waypoint is selected in Edit mode and <Delete> is pressed, the waypoint and the wires connected to it will be removed.

5.3 Revision History

<table>
<thead>
<tr>
<th>Revision</th>
<th>Date</th>
<th>Changes</th>
</tr>
</thead>
<tbody>
<tr>
<td>UM1</td>
<td>July, 2006</td>
<td>Initial Release for CS495XXX product.</td>
</tr>
<tr>
<td>UM2</td>
<td>March, 2007</td>
<td>Release for CS4953XX &amp; CS497XX &amp; CS485XX products.</td>
</tr>
<tr>
<td>UM3</td>
<td>May, 2007</td>
<td>Converted to multi-chapter format for CS4953XX &amp; CS497XX &amp; CS485XX products.</td>
</tr>
<tr>
<td>UM4</td>
<td>October, 2007</td>
<td>Updated chapters to reflect latest release of DSP Composer. Moved all board set-up information to Chapter 1.</td>
</tr>
<tr>
<td>UM5</td>
<td>October, 2008</td>
<td>Update document to match latest release of DSP Composer</td>
</tr>
<tr>
<td>UM6</td>
<td>February, 2012</td>
<td>Updated Chapter 1, “Controlling a Cirrus DSP on a Customer Board” to include information regarding how to use JP1. Changed “workspace” to “design canvas” throughout.</td>
</tr>
</tbody>
</table>